El triángulo equilátero

Vamos a ver cómo trazar este triángulo equilátero de 180 pasos de tortuga.

Las órdenes serán algo del estilo:

repite 3 [av 180 gd ...]

Queda por determinar el ángulo correcto. En un triángulo equilátero, los ángulos valen todos 60 grados. Como la tortuga debe volver por el exterior del triángulo, el ángulo valdrá 180 - 60 = 120 grados.

Las órdenes son, pues:

repite 3 [av 150 gd 120]

Aquí, un cuadrado representa 30 pasos de tortuga.

Image 02_Triangulo



Loïc 2007-10-30